1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

asssasin creed laggy ...

Discussion in 'PC Games' started by hitman47222, Aug 10, 2009.

  1. hitman47222

    hitman47222 Dedicated Member

    well laggy is not the right word as the game works at normal speed with highest textures and resoloution ... so what is it >?? lets start ..

    OKAY ... i bought assasins creed 3 days ago ... installed it and everything was fine ... yesterday i was in a hurry so rather than closing the game normaly i used alt+f4 ... went to sleep then woke up today ... the game takes a little bit longer now to load than yesterday ... but thats not the problem ... the problem is that the game now runs like a video buffering ... cause it runs for like 3 mins then freeze ... then run normal again ... even in the intro cutscene and even in the main menu ... probably the first 2 things that will come to ur mind ... either hardware issue or game isssue ... well not either ... why ?? well i reinstalled it and its still the same so that remove the game issue ... so its hardware ??? well no ... for 3 reasons ...

    1) i pass the recommeded (not all) requiments in canyourunit.com
    2) i bought the pc last week .................
    3) i run COD4 ... FUEL .. COD WAW (demo) ... POP4 ... all of them run without lag at all .. on highest texture and resoloution ...


    SO ... what is it ??? why the game stops like that ??? even though it worked fine b4 ...


    PC spec :

    OS : windows vista ultimate 32 bit
    CPU : AMD ATHLON II X2 250 3.00 ghz
    RAM : 2gb (thats why i dont pass all recommended requirments since vista requires at least 2 for ac)
    video card : ATI RAEDON HD 4730 ..


    well thats it ... if u need any information .. post as reply ...

    thanks for help :D:turned:
     
    Last edited: Aug 10, 2009
  2. hitman47222

    hitman47222 Dedicated Member

    well ... sorry lads ... another post solved ... i need to stop rushing putting the post here :( ...

    anyways appearntly when i started the game and it started the stopping and stuff my internet was not working. .. anyways when i installed the game and run the game launcher it started downloading an update ,, after the update is installed it asked to installed i chose yes and it gave an error ... so i restarted the launcher asked for the install again i chose no ... anyways the game worked fine after that so now it did not ask me for the install cause there was no internet so the stop thingy happened .. so anyways its all working again yay :D