1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cant boot

Discussion in 'Older Windows Versions' started by nukecad, Jan 11, 2009.

Thread Status:
Not open for further replies.
  1. nukecad

    nukecad Established Techie7 Member

    I have copied this from another thread in the hope that a wider audience can help me.

    I cannot boot up into windows at all.
    When I try to boot in normal or safe modes I get the error message-

    ' Write protect error writing to drive C
    Abort, Retry, Fail? '

    and can go no further regardless of which response I give.

    I CAN boot into DOS but if I then type in WIN to go to windows I get the longer error message-

    'EMM386 has detected error #à6 in an application at memory address 30E0:0FDE. to minimise he chance of data loss, EMM386 has halted your computer.
    For more information consult your documentation.

    To restart your computer press ENTER. '

    Pressing ENTER gives no response.

    To try and simplify things I have dissconected the optical drives just leaving the hard disk and floppy drive connected. I have tried swaping IDE cables and connecting the hard disk to each of the IDE ports on the motherboard, but still get the same errors whichever connection / cable I use.

    I have tried turning off EMM 386, made no difference.

    Any ideas would be very welcome.

    Ive just been reading a post that seemed to be of a similar (but not quite the same) problem and this has prompted me to add the following info.

    I DO NOT have the original Windows 98 CD.
    (It is a second hand machine but apparently Advent do not ship the CD with new machines anyway).

    I DO have a 'Windows 98 Recovery Disc V1.02' floppy which was shipped with machine but even this gives a write error (on drive A:)

    The laptop that I am posting this from does NOT have a floppy drive, so copying and posting files from the problem machine may be awkward.

    I hope that someone here can help otherwise I will just have to junk the machine and I hate waste.

    Nuke.
     
  2. townsbg

    townsbg Senior Member

    Initially that sounds like an error related to a corrupted file system, but if you can boot into dos then that is less likely to be the case. I'm guessing that part of windows is corrupt and perhaps part of dos. The EMM386 application is a memory expander for dos. Basically dos can only use a certain small amount of memory (no matter how much you have) so expanders here written to allow users to use more memory. My guess is that if this file is corrupted then dos doesn't have enough memory to work with in order to launch windows. If you can't boot directly into 98 then part of 98 is also corrupted which might or might not just be the boot files. All I really can do is to explain what the problem might be but I don't know what to tell you to do to fix it and I'm not even for sure that that is the problem. The easiest way to do so would normally be to reinstall windows. If you can find a copy of that file and you can find out where it goes then you might be able to use dos to run windows however if more than just the boot files or corrupted then you probably won't be able to use windows anymore without a reinstall. By the way you can get an external floppy drive but this computer might not even be worth it. If you want to though try newegg.com. They are only about 20-25 usd. If this error doesn't have to do with EMM386 being corrupted then it could have to do with it not being able to launch windows. Sorry but this is all I can offer. Perhaps someone else will have something.
     
  3. nukecad

    nukecad Established Techie7 Member

    Thanks townsbg

    I am still trying various things and trying to boot step-by-step to see if I can identify any missing or corrupted files. I wish I knew more about boot routines and could remember DOS.

    I will hang about and see if anyone else can suggest something.

    Cheers

    Nuke.
     
  4. Dan Penny

    Dan Penny Staff Techie7 Moderator

    Make sure your Win98 hard disk is the MASTER drive on IDE 0 (or 1 depending on your motherboard labeling).

    Enter your bios. Ensure write protection is OFF for all drives.

    With Windows 9x you have the luxury of running scandisk in DOS. It's much faster. This is an asset if you have large partitions on your hard disk.

    Boot your machine into the DOS Command Prompt Only mode. When the machine is booting, just after the P.O.S.T. (Power On Self Test) screens finish and you see "Starting Windows 98", start tapping the Ctrl key. (You have to be quick.) This should bring up the MS boot menu. Choose Command Prompt Only.

    (OR, use a Win98SE Boot Disk*)

    When the boot completes, at the C:\> (or A:\>) prompt, type in scandisk /all/autofix/nosave/nosummary and hit the Enter key. All of your drives (partitions) will be scanned and fixed if problems exist. When the process is finished, reboot the machine to the MS boot menu again and choose Safe Mode. This will load windows with minimal drivers etc. Defrag in safe mode.

    Caveat: The drawback to booting into Safe Mode is that your desktop icons are automatically arranged, and if you had your own arrangement, you will have to recreate that arrangement in normal mode. Windows doesn't provide a save feature for your icons. There are (free) third party programs available which will save your desktop arrangement.


    To save you some typing and possible DOS syntax errors (DOS is VERY PARTICULAR about the command line entries,) I'll paste in a dos 7.x ( 95/98 ) batch file I made long ago to automate this process. On a working machine, Open Notepad and copy/paste the following lines into the empty document. Save it as scandrvs.bat in the root directory of C:. (ie; c:\scandrvs.bat) Transfer it from a floppy if need be.

    ===== Copy lines below ==========================
    @echo off
    %WinBootDir%\command\scandisk /all/autofix/nosave/nosummary

    echo.
    echo.
    echo Scandisk has completed. You can now restart your system.
    echo.
    exit

    ===== End copy at above blank line ==============

    When you get the C:\> (or A:\>) prompt, simply type in scandrvs and hit the Enter key.


    *The above bootdisk image file is a self extracting file and has to be executed (run) from a running Windows machine in order to create the actual startup diskette on one of your floppy disks. (This image file produces the same bootdisk which 98SE creates.) This downloaded image file will format the floppy disk to ensure its integrity, write the files to the disk, then verify the file write, so it'll take a minute or three to create the bootdisk.

    Ensure the floppy drive is set as the first boot device in the bios.

    NOTE: When you boot a machine with this boot floppy, it creates a RAMDRIVE in system memory to contain DOS system tools/drivers. Thus it will move your "normal" CDROM device/drive letter "up" one level. (If your CDROM is normally E: it will be F: when booting with this bootdisk.)

    The path to the found CDROM will be set with the bootfiles, so entering (example) A:\>f:\setup is the same as entering A:\>setup at the A:\> prompt. There is no need to include the cdrom drive letter. The path dictates that the instruction (command line input) will look at the CDROM for Setup before it looks elsewhere. The CDROM device letter will be assigned near the end of the floppy boot process, right after MSCDEX is loaded.
     
    Last edited: Jan 16, 2009
  5. nukecad

    nukecad Established Techie7 Member

    Thanks Dan

    Not sure I understand all that at first reading, (I have just spent the last 13 hours travelling by bus and train to a hospital appointment in another city).
    The initial scandisk bit is simple enough and is where I will start, (and I will read the rest again), tomorrow after I have had some sleep and recovered from todays journey.

    Cheers

    Nuke.
     
  6. nukecad

    nukecad Established Techie7 Member

    Could you explain this a bit more please? I dont think I know how to enter the BIOS or how to turn write protection off from there.

    Im always willing to learn new things though.

    Nuke
     
  7. Dan Penny

    Dan Penny Staff Techie7 Moderator

    Click on the word "bios" (in Blue) in my #4 post. This will provide an overview of the bios.

    Generally, on the first screen you see when you start your machine, there will be an instruction on how to enter the bios setup. ie; "Press Del to enter Setup" or "F2 for Setup" etc.

    Once you're in, EVERY screen has navigational and function keys outlined. ie; ENTER, ESC, Arrow Keys, Page Up, Page Down, etc.

    Just use your arrow keys to select an area or an option, and (usually) the ENTER key selects it. The ESC key usually backs you out of an area or option.

    Hunt around for any description of Write Protecting drives. If you find one, ensure it's DISABLED.

    Also DISABLE any bios anti-virus protection or MBR (Master Boot Record) protection if it exists.

    Any changes must be SAVED and CONFIRMED on exiting the bios. The machine will automatically reboot on exiting.

    Post back with your results and any further questions.
     
    Last edited: Jan 16, 2009
    1 person likes this.
  8. nukecad

    nukecad Established Techie7 Member

    Thanks Dan
    Will let you know how I get on.

    Nuke
     
  9. nukecad

    nukecad Established Techie7 Member

    Sorted Thanks!

    Dan

    I think you should change you name to DAN- THE- MAN.

    Got into the bios and had a look as you advised.

    In 'BIOS Features Setup' both the 'Floppy Access Control' and the 'Hard Disk Access Control' were set to read only.

    Set them back to read-write, saved and exited; the machine rebooted straight up into windows normal mode.

    I will now scandisk and defrag (and make a new boot floppy) before going back to my original optical drive problem, but I think that even that was just the DVD drive being mechanically kaput.

    Once again thanks a lot for your help; if you ever have a question about Autocad I will be pleased to reciprocate the favour at AutoCAD Everything - AutoCAD Help Forum

    Cheers again

    Nuke.
     
    Last edited: Jan 16, 2009
  10. Dan Penny

    Dan Penny Staff Techie7 Moderator

    Glad it worked out. Plus you're now more familiar with the bios.

    Let me know if you consider this issue resolved, and if so, I'll close this thread.
     
  11. nukecad

    nukecad Established Techie7 Member

    Yes issue is resolved and thread can be closed.
    Thanks again.
     
  12. Dan Penny

    Dan Penny Staff Techie7 Moderator

    This thread has been resolved and locked to prevent other users from hijacking the thread and to help others know which threads have been resolved and which are still being worked on.

    If you started this thread and the problem returns, or, the case has not been properly resolved, please send a Private Message to a Moderator to have the thread opened again. If you have a different problem, please start a new thread in the appropriate forum.
     
Thread Status:
Not open for further replies.