1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

5.1 Surround Sound

Discussion in 'Alternative Operating System Help' started by TaZMAn, Jan 9, 2009.

  1. TaZMAn

    TaZMAn Techie7 New Member

    Using Ubuntu Ibex 8.10.
    Just hooked up my 5.1 surround sound speakers to my computer and can only get stereo. Front left and right.

    Do a surround sound test and I get the front left and right to produce sound.
    Rear speakers are dead. Center channel is dead until the test puts an output to the LFO bass speaker. Then the center channel speaker will play.

    Read that Pulse Audio is a major culprit and should be removed then use Alsa.
    Figured that back when I used Gutsy and had these speakers hooked up I was able to get surround sound fixed by editing the asound config file.
    Doesn't work in 8,10.

    BTW.... The audio device is a built in Nvidia ALC861 VD audio chip.

    Without the sub woofer it sounds like a bunch of tin cans rolling down an alley.

    Thanks for any help.
  2. rokytnji

    rokytnji Dedicated Member

  3. rokytnji

    rokytnji Dedicated Member

  4. rokytnji

    rokytnji Dedicated Member

  5. rokytnji

    rokytnji Dedicated Member

    Got this from a forum dealing with surround sound in 8.10.

  6. rokytnji

    rokytnji Dedicated Member

  7. TaZMAn

    TaZMAn Techie7 New Member

    Hi Rok!
    Thanks for the links. Have seen several of them but you got me some new ones!
    Tried changing the channels from 2 to 6 while I had pulse audio installed but it didn't help.
    So like I said, some advice was to remove pulse audio and configure the whole system to use Alsa.

    I just came across another odd issue. When I play a movie in MPlayer that is encoded with 5.1 sound and try to change the preferences to 5.1 in MPlayer I get an error message that it can't change it because Alsa is in use.

    I will work it out. I think the problem stems from the fact that when I installed Linux I was using a set of stereo speakers and Ubuntu configured the Alsa and Pulse Audio to 2.0
    Now I added these speakers and Alsa and PA weren't compiled to use 5.1

    I may just uninstall Alsa and reinstall Alsa and PA.
    Not sure yet. And I still have that dual boot grub issue. LOL!!
    I got plenty of issues but I won't talk about them here! :taz:
    Still have an audio project to finish then I can crack the whip on fixing these two problems.
    I think the grub issue will be solved if I remap my drives within Linux.
    Then grub will be able to find the right partitions.
    If not, I will manually write my grub loader entries.

    Thanks again and if you come across any other 5.1 surround fixes I'd sure appreciate if you or anyone else would post them.
  8. rokytnji

    rokytnji Dedicated Member

    When you type "alsamixer" into terminal, does it comes up. Thats probably why Mplayer states it in use. I just run stock usb stereo on board sound setup. Under Sound properties I use intels Alsa Sound Mixer. Funny How Pulse Audio does 1 thing and alsa is needed for another. Especially when alsa can run stand alone. Confusing to a guy like me.
    Last edited: Jan 10, 2009
  9. TaZMAn

    TaZMAn Techie7 New Member

    Not just you Rok.
    Confusing to many people.

    Linux needs to gel all these different sound daemons into one standard.
    From my understanding, Pulse Audio was introduced as a network sound server.
    But before it was packaged into Hardy and later Ibex, not many people knew of it or even heard of it.

    And to make things worse, the creators of PA decided to disable 5.1 surround sound by default.
    Now it's created a hassle for many users to configure everything to work in 5.1
    I could go for a simple GUI right now! LOL!

    Another confusion is that Alsamixer reports my audio device as Nvidia and my Audio Chip as Realtek.
    I know that the Realtek is the surround sound encoder but don't know if it is patched in to my Nvidia device.

    Aaahhh! The joys of audio. Some times I think setting up printers and video is way easier!
  10. TaZMAn

    TaZMAn Techie7 New Member

    Just an update on this situation.
    I now believe this audio device is only partially supported in Ubuntu 8.10 and not supported in other distros.
    I ran 2 'Live' disks to check out the audio performance. This disks were Mandriva and Sabayon.
    Both properly detected the audio device but in these distros I had absolutely no sound.
    I checked alsamixer from the terminal and all the volume sliders were unmuted and full volume.
    Mandriva actually gave me an error message that the file /dsp was not found.

    So I will toss in an old SB Live 5.1 card I have laying around and see if I can get surround sound with it.

    Will post back when I get it done.
  11. rokytnji

    rokytnji Dedicated Member

    Hardware Blues.:hammer: Too Bad there aren't enough of us to write the drivers for all scenarios, or that hardware vendor management run with blinders on.

    Don't feel bad Taz, This forum is full of threads where sound won't work in Windows either, and thats with Manufacturer supplied Windows drivers.
    Last edited: Jan 15, 2009