1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to set up a Home Network?

Discussion in 'Firewalls and Networks' started by kyle_fei, Jan 12, 2007.

  1. kyle_fei

    kyle_fei Techie7 New Member

    I have two computers in my room. I have a DSL Modem and a Linksys router connected to it. Both computers are connected to the router with ethernet cable. How can I make these computers into a network station (connected). So I can play LAN games with it.?
     
  2. kyle_fei

    kyle_fei Techie7 New Member

    How to set up a LAN game with two computer?

    I have two computers in my room. I have a DSL Modem and a Linksys router connected to it. Both computers are connected to the router with ethernet cable. How can I make these computers into a network station (connected). So I can play LAN games with it.?

    I saw the microsoft site where it teaches you, but it didn't helped me a lot. I also cannot get help from the Network forum so i post this here. Thank you
     
  3. DJNafey

    DJNafey UK site moderator

    You need the router to have DHCP enabled so that it allocates an IP address and Default Gateway to both PCs. Then, if you are running Windows XP, you can simply run the Network Setup Wizard (which you can find in My Network Places) on both PCs and that will guide you through the process of getting them both networked together.

    Let us know if that helps :)
     
  4. Kaistar

    Kaistar Dedicated Member

    Re: How to set up a LAN game with two computer?

    well, this might not be what you want, but even though i'm connected through a network i don't know how to set LAN the normal way either.

    what i use is a program called Hamachi. uses very little resource, totally free. it typically just connects you to any one online, and tricks whatever game that has LAN function to believe that instead of being connected through the net you're connected through LAN.

    to start, simply download hamachi, set up an account *10 secs needed* and create a network *another 10 secs needed*.

    after that, just give your friends or whoever the network name and password, ask them get hamachi of course, and use hamachi to connect to your network.

    www.hamachi.cc

    hope this helps. though it isn't exactly networking.
     
  5. Kazna3

    Kazna3 Techie7 New Member

  6. kyle_fei

    kyle_fei Techie7 New Member

    Connecting to the same workgroup, error occurs

    When I stablished the network configuration using the Network Setup Wizard. I restarted, and I tried to go to"View Workgroup computers" to see if it was successful, and this appeared:

    [​IMG]

    anyone have any clue? thank you!
     
  7. kyle_fei

    kyle_fei Techie7 New Member

    Can you explain in detailed how especifically you do that? thank you!
     
  8. DJNafey

    DJNafey UK site moderator

    Which part - running the wizard or enabling DHCP?
     
  9. DJNafey

    DJNafey UK site moderator

    Kyle_fei,

    I see that you are now running 3 threads for what appears to be the same problem. This makes it very difficult to help you if other members are going to give different advice about the same problem in different conversations. I am now going to merge the threads together. In future, please keep a problem to a single message thread. Thanks.
     
  10. DJNafey

    DJNafey UK site moderator

    Three threads now merged into one. The flow of this thread now might or might not still make sense!
     
  11. kyle_fei

    kyle_fei Techie7 New Member

    I am sorry about making inconvinience for you and the others :(

    What I was asking is how to enable DHCP, more especifically how to check if I have it ON or OFF and how to enable it.

    I would also like to ask if I did anything wrong with the wizard and about the problem occured in the screenshot i post.

    Thank you very much!
     
  12. Kazna3

    Kazna3 Techie7 New Member

    You need to have a DHCP server for it and its provided by your ISP not at your own reckoning. A DHCP lease is given which is the amount of time that the DHCP server grants to the DHCP client the permission to use a particular IP address. When it expires you have a different IP address.

    I'm quite curios why you want to have a Dynamic IP specifically?
     
  13. kyle_fei

    kyle_fei Techie7 New Member

    Oh....that sounds a bit complicated.
    Well the reason...not is that I want a Dynamic IP. I just want to make the two computers of my room "networked", so I can use that to play LAN game between the two computers. As I mentioned before, I have two computers in a room, and I have a modem connect thru telephone line (DSL), and the modem is connected to a Wirless router with 4 ethernet port. Which my both computers are connected to each port.

    Here is a basic drawing of how my computer are connected in my room:
    [​IMG]
     
  14. kyle_fei

    kyle_fei Techie7 New Member

    HEY GUYS I JUST FOUND OUT!
    My DHCP is enabled!! I found it in my Router Setting site. And it says enable for maximum user of 50. So I think for that part i have passed. Then what is the problem? Did I messed up with the Network Wizard? :S

    Here is a screen shot of my Local Area Network Status, I don't know if that helps:
    [​IMG]
     
    Last edited: Jan 21, 2007
  15. kyle_fei

    kyle_fei Techie7 New Member

    hello any help please?
     
  16. DJNafey

    DJNafey UK site moderator

    Hi Kyle_Fei,

    Now that I've seen your diagram, I understand your configuration a little differently.

    Do both PCs connect to the Internet OK? If they do, then DHCP is successfully working between the router and both PCs - the router will have given each PC a unique IP address between 192.168.1.100 and 192.168.1.149.

    If both PCs work on the Internet, then the physical network is working correctly and the problem is due to permissions, firewall blocking or incorrect workgroup settings. The simplest one to check first of all is the workgroup name. Right-click 'My Computer', go to Properties and then select the Computer Name tab (if both PCs are Windows XP). Check the 'Workgroup' name. It should be the same on both PCs.
     
  17. kyle_fei

    kyle_fei Techie7 New Member

    After checking if the workgroup is the same, how can I check about the firewall?

    Ok, I have checked, My both computers' Workgroup's name are the SAME. SO.. do you see any problem in the screenshot I took?
     
    Last edited: Jan 29, 2007
  18. DJNafey

    DJNafey UK site moderator

    Do both PCs connect to the Internet OK?

    There could be one or more firewalls blocking the communications. Firstly, confirm if you have the basic Windows XP firewall enabled on the network connection. To do this, go to Network And Dial-Up Connections, find your 'connected' Local Area Network Connection, right-click it, select Properties, select the Advanced tab, click Settings and let us know whether Windows Firewall is on or off.
     
  19. kyle_fei

    kyle_fei Techie7 New Member

    Yes the both pc connects to the internet perfectly.
    I DO have the Windows Firewall ON.

    Thank YOu
     
  20. kyle_fei

    kyle_fei Techie7 New Member

    SO...any help :D?