1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to load operating system with not internal drives

Discussion in 'Drivers' started by bryansmiley, Jun 21, 2005.

  1. bryansmiley

    bryansmiley Techie7 New Member

    I have bought a IBM Thinkpad 560Z laptop with no operating system or internal drives. I want to load XP onto it. I have bought an IBM external CD ROM drive - USB 2.0 with optional split PS2 connectors.

    I have tried connecting it from the cd drives USB to the PS2 on the laptop, it lights up and I can put the bootable XP CD in the drive. However the same startup screen always comes up on the laptop.

    It is a picture of a floppy disk, with all the F keys along the bottom, the picture of F1 pressed down, and pressing between F1 and F8 just stays in a black screen, and gives "I9990302 I9990302 I9990305" if that means anything. You can't go any further.

    Is this because there is no driver for the drive? The USB driver is on a floppy disk, but does it need this going from USB on the drive to the laptops PS2? Do I need to get an external floppy drive and install it/another driver, to then install XP?

    What's the easest way to get XP on this machine?
     
    Last edited: Jun 21, 2005
  2. DJNafey

    DJNafey UK site moderator

    You'll never be able to use the CDROM through the PS2 port I'm afraid. The PS2 port was only designed for mice or keyboards - it's not a data channel suitable for transferring information from disks (including CDs).

    This might seem like an obvious question but does the laptop have a hard disk installed inside it? Technically, when you say that you have "no internal drives", that actually tells us that you've got no hard disk but I'm guessing that's not what you meant ?

    Does the laptop have a USB port and, if so, did you try connecting the external CD drive to it?
     
  3. bryansmiley

    bryansmiley Techie7 New Member

    Yes it does have a hard drive, and all specs are sufficient. It has USB and I have tried USB - USB connecting but its the same, the cd drive lights up and allows you to open it, it sounds like its reading it, but the black screen of a floppy disk and all the F1 keys is still all you get.

    You also get this much using PS2, does this mean the PS2 is working (as light is on and sounds like it reads CD like with USB) or that the USB connecting is NOT working?
     
  4. DJNafey

    DJNafey UK site moderator

    The CD drive being connected into the USB port is not doing what it should. However, it probably isn't a problem with the port - it's more likely to be a BIOS configuration issue. When you switch the laptop on, go into the BIOS ("System Setup") screen, which you normally do by pressing F1, F2, Delete or Escape (it will normally indicate what to press in a message on the very first screens that appear .... before it tries to find a hard disk / floppy / CD to boot from.

    Once in the BIOS screen, look for the boot order settings. You need it to check for the CDROM drive before it tries to boot from the hard disk. Sounds like it might be set up to check for a floppy drive before the hard disk instead of the CDROM drive. Bear in mind that the 'CDROM' drive option normally refers to an internal drive so you might have a different option for 'USB drive' or something like that.

    Let us know what happens after you've checked that setting.
     
  5. bryansmiley

    bryansmiley Techie7 New Member

    I have tried connecting an external floppy drive via USB to no prevail. I've also tried connecting it via a PS2 connector which although Ive learnt wouldnt work, actually sounded like it powered the floppy drive for a moment, whereas the USB did not.

    I tried downloading a Win98 boot disk from here http://freepctech.com/pc/002/files010.shtml
    and whether its connected or not, the laptop shows you all the F1 keys with a picture of a floppy. Pressing any of the F keys takes you to a black screen that just gives you "I9990302 I9990302 I9990305" again you cant go any further.

    Anyone know whats going on here, what can/should I do?
     
  6. DJNafey

    DJNafey UK site moderator

    When you created the boot disk, did you just copy the file that you downloaded onto a disk? Or did you follow the instructions on the site to run the downloaded EXE file, which extracts lots of smaller files onto a formatted floppy disk?
     
  7. Funnyman2003

    Funnyman2003 Techie7 New Member

    The thinkpad 560z has no bios option to boot off a usb cdrom, you would have to purchase an ibm portable cd-rom drive, made for specifcally for the tp560z. If you have a desktop computer with a bootable cdrom, buy an ide 3.5" to 2.5" drive adapter, plug your laptop's hard drive into desktop computer instead of its normal hard drive, and install the os, then put it back in the laptop.
     
    Last edited: Jul 7, 2005
  8. bryansmiley

    bryansmiley Techie7 New Member

    DjNafey, I followed the guide, it produced a floppy with lots of files, the progess level completed, and it all closed fine. When I put it in the laptop nothing happens, I dont get it. I tried it on another computer to check, and it said disk I/O error.

    This is via a 25 pin parelell to centrix connector that came with the floppy drive, and I've tried USB too.

    What now?
     
    Last edited: Jul 11, 2005
  9. DJNafey

    DJNafey UK site moderator

    If the floppy drive in the other PC works OK, it sounds like you might have a duff floppy disk (I've noticed that floppy disks generally seem to be much less reliable than they used to be).

    Try formatting the disk in the second PC (right click the A: drive in Windows Explorer to get the Format option). Then copy any file to the floppy disk on the second PC. If it works OK, delete the file. Then take the floppy disk back to the laptop and try to create the boot disk (or download it on the second PC and create the disk again as you did before). Then see if that boots your laptop OK. Let us know how you get on :)
     
  10. bryansmiley

    bryansmiley Techie7 New Member

    Tried that already. Formatted it in all ways possible too. No difference, and on the other computer, disk I/0 error!?
     
  11. Funnyman2003

    Funnyman2003 Techie7 New Member

  12. awbker

    awbker Techie7 New Member

    I stumbled upon your problem with the 560z..I have the same problem...did you get your laptop up and running? if so how did you do it?
     
  13. Funnyman2003

    Funnyman2003 Techie7 New Member


    yes i have over come my problem

    1. i got a 3.5" ide to 2.5" harddrive adapter
    2. put the harddrive in my desktop computer which has a bootable cdrom drive, then i installed windows 98se 98fe works too. Windows xp will not work, niether will windows 2000 or any of the windows NT s.
    3.when the instalation proccess was done i explored the cdrom and copied the folder D:win98 to my harddrive. (D: is my desktop's cdrom drive)
    4. when i put my laptop harddrive back in my laptop and windows wanted the new driver files i took them from were i copied the win98 folder to. after that it should work.

    in fact im typing this message on my laptop

    pm me if you need any help