1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Canon MP370 - Scanner problem

Discussion in 'Drivers' started by DXD, Feb 21, 2005.

  1. DXD

    DXD Techie7 New Member

    Hello, thought Id give it a try here.

    Well, my scanner on the mp370 works fine on my brothers computer, he got Windows XP Pro SP1.
    But when I try to scan on my own computer (Windows XP Pro SP2) it just hangs up. Cant find the solution anywhere...

    I have done all that Canon's helpdesk said I could try, reinstall, try all usb ports and so on, nothing helps.
    Well, the only thing that helped was to scan on my brothers computer, but I need it to work on this one.

    Can the windows drivers be defective? I have installed drivers from the cd but I doubt it's those drivers windows uses.
    Can I delete any windows drivers?

    Any help/tips is appreciated.
     
  2. wildthing

    wildthing Techie7 New Member

  3. DXD

    DXD Techie7 New Member

    I have tried that already. Didn't help me. Thanks anyways. Anyone else? Im getting desperate here... ****tie :mad: :confused:
     
  4. jephree

    jephree ¨*·.¸ «.·°·..·°·.» ¸.·*¨

    Did you ask Canon's helpdesk if they had any SP2 issues?

    Have you looked in the Device Manager?

    Device Manager: RT click My Computer then click Manage then Device Manager

    If you double click the device you will get driver options.
     
  5. DXD

    DXD Techie7 New Member

    Yes I asked them, they replied that they use SP2 and the mp370 works fine over there.

    And it says that it uses the Canon driver.
    Hmm, what the ... is the problem. :confused:
     
  6. AphJN

    AphJN Dedicated Member

    Long shot, is the Firewall on?
     
  7. DXD

    DXD Techie7 New Member

    Nope.
    I have even tried without any antivirus apps running etc.
    Nothing seems to help, always the same, the scanner hangs up.
     
  8. AphJN

    AphJN Dedicated Member

    Just to review:

    It worked fine before SP2 was installed.
    It works fine on an SP1a machine
    Drivers have been reinstalled per Help line

    Where in the scan process is it stalling? Transfer of Info or just starting to scan?
     
  9. DXD

    DXD Techie7 New Member

    Just when I start to scan.
    I think I got to "2%" on the process bar a while ago, thats the best I can get.

    Then the process stops, and if I dont press cancel directly, the scanner will stall completely,
    and I have to restart it by removing the powercord from it.

    It's the same with the Canon's scanner application and the windows scanner wizard.
     
  10. jephree

    jephree ¨*·.¸ «.·°·..·°·.» ¸.·*¨

    Do you see anything relavent in the Event Viewer?

    event viewer: rt. click My Computer then click Manage then Event Viewer.
    open the system as well as the application tabs & look for X errors. click error line for details. post back the source & event id especially of errors that seem to coincide with a scan attempt.

    Or attempt a scan & note the time. Then check the E.V. It lists errors by time.
     
  11. DXD

    DXD Techie7 New Member

    Here's the error:

    ID: 11
    Source: Disk
    It says that the drivers got some errors @ \Device\Harddisk2\D
     
  12. jephree

    jephree ¨*·.¸ «.·°·..·°·.» ¸.·*¨

    Can you ID the scanner from either of these?

    MP370

    another MP370

    Do the other devices work? Printer?

    Is your USB 2.0?

    That error 11 from Disk, besides drivers, also mentions S.M.A.R.T features as well as IDE cables. Can you trace this path: \Device\Harddisk2\D?

    Can you post the full details of your particular error? (description) (click error for details)

    When you tried to uninstall & reinstall did you do so via the Control Panel > Printers etc.? Did you manually remove all files & registry entries?

    Sorry for all the questions. Hope this is getting somewhere :confused:
     
  13. DXD

    DXD Techie7 New Member

    That's the scanner or.... wait, whats the difference between those anyways? :)
    Everything else works fine, printer works without any probs at all.
    Copying etc. works fine too.

    My USB should be 2.0. Where can I see it to be 100% sure? :confused:
    I have tested it with an old usb 1 cable too but no help.

    The details were just about what I posted before.
    There was an microsoft help link too but there wasn't any help available there.

    Yes, I have uninstalled it that ways too. Removing everything that is.
     
  14. jephree

    jephree ¨*·.¸ «.·°·..·°·.» ¸.·*¨

    Have you tried the "Interactive Troubleshooting" on this page?

    MultiPASS MP370
     
  15. DXD

    DXD Techie7 New Member

    Tried that now, didn't help. :(

    Argh.. I just don't understand why it doesn't work.
    It has to be something simple, but what.

    Im going for a nap now, trying to reinstall it again when I wake up.
    If you don't have a good solution. :p

    Ps. That Disk error is kinda strange, it says Harddisk2/D... D: works fine?
    I don't even use D: when I try to scan.
     
  16. jephree

    jephree ¨*·.¸ «.·°·..·°·.» ¸.·*¨

    ok then quickly found this:

    2 quotes from following thread:

    "Well, this is interesting. Disk 2 turns out to be the Compact Flash reader that's
    installed in my photo printer. Does this error mean that Windows "thinks" the card
    reader is a hard drive, and it's trying to access it and failing because there's
    no media in the drive? The Computer Management applet knows that this is a removeable
    drive, but it is labeled Disk 2. "

    "No conflicts reported. I'm pretty sure this relates to the Compact Flash slot on
    my printer, which perhaps is being regarded as an IDE drive by the system, perhaps
    when some other program polls the available drive. I'm wondering if there's a way
    to get the system to ignore this drive short of disabling it. I don't use it very
    often, so I guess disabling it would work, but as the system doesn't have any trouble
    with my other card reader it seems there's something specific to the way this drive
    is being treated that I could correct. Ideas?"

    thread
     
  17. DXD

    DXD Techie7 New Member

    That's my "problem " then?
    I found out now that C: is Disk0, D: Disk1 and when I turn the mp370 on, the cardreader is Disk2 H:.

    I tried to uninstall just the reader, but that didn't help.
    Im trying various things right now.

    I installed the drivers from the canon website, which should be the same as the drivers I have been trying with all the time.
    Just a moment ago I got to "15%" on the process.
    I was thrilled! :D :D But as in lottery, it lets one down. :(
     
  18. jephree

    jephree ¨*·.¸ «.·°·..·°·.» ¸.·*¨

    It seems to me that the above scenerio is pretty close to yours.

    Perhaps test by unplugging the D: drive?
     
  19. DXD

    DXD Techie7 New Member

    Doesn't seem to help. Reports same error besides now it's on "Disk1" of course.
    Tried to change the reader from H: to D: and scan, but that didn't help either.
     
  20. jephree

    jephree ¨*·.¸ «.·°·..·°·.» ¸.·*¨

    Is there anyway not to use the card reader?

    In that other thread I see they went to an external card (in the computer).

    Anyway I wonder if Cannon would have a response to the drive confusion issue?

    Otherwise I will go back to the drawing board.

    Any interest in uninstalling SP2? Or trying the scanner on another SP2 machine?


    ...
     
    Last edited: Feb 26, 2005