1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Administrator user has insufficient privileges for restore utility

Discussion in 'Windows XP Help' started by sfcardwell, Dec 29, 2008.

  1. sfcardwell

    sfcardwell Techie7 New Member

    Messages:
    2
    Operating System:
    Windows XP
    I'm running XP (from its final 2 weeks), on a well firewalled non-networked system. My system has only 2 users: Administrator (hidden) and Steve. In trying to run the system restore utility as Administrator to manually set a restore point, the utility tells me "You do not have sufficient security privileges to restore your system. Please contact your administrator or logout and log in again as administrator and try again." Am I somehow missing another hidden user with administrator rights, or did I screw up the setup of the machine six months ago?
    Steve
  2. townsbg

    townsbg Senior Member

    Messages:
    2,195
    Operating System:
    MAC
    What version of XP do you have [Is it home or pro]? It seems like Administrator is disabled which is how it is by default on XP installations especially on manufactured systems. If you have home you will not be able to access Administrator or use that account at all [in other words no run as] but if you have pro then you can after you've enable it. Is "Steve" an administrator? If so then you should be able to run system restore manager as "Steve" & do whatever you need to do.
    Last edited: Dec 29, 2008
  3. allsecur3

    allsecur3 Techie7 New Member

    Messages:
    2
    Operating System:
    Windows XP
    That thing also happened to me, I was virus infected that time.
    Try scan your PC with onecare from microsoft, its a free online scan facility.. its very good.

    i hope this helps
  4. Dan Penny

    Dan Penny Staff Techie7 Moderator

    Messages:
    4,460
    Operating System:
    Windows XP
    When you install XP, either version, you get a built in admin account named "Administrator". This account is partially hidden. It is only accessible in XP Home Edition through a safe mode boot. In XP Pro it is hidden by default from the Welcome Screen.

    The retail version of XP will hide the Administrator account as soon as you create another account. (When you create another user, the main admin user disappears from the welcome screen.)

    To access the main administrator account, log off all users and hit Ctrl+Alt+Delete twice on the welcome screen. This will give you a Windows 2000 style login box where you can select the main admin user. NOTE: Many OEM installs come with an initial "Owner" account, which is an ADMIN account.

    If you create several accounts during setup and never logon to Administrator, you won't see the Administrator profile.
  5. townsbg

    townsbg Senior Member

    Messages:
    2,195
    Operating System:
    MAC
    Dan if the Administrator account is disabled then he won't be able to log in. Also allsecur3 he said that he is on a non-networked system. If that mean that he isn't connected to the internet then it would be hard, but not impossible, for him to get a virus. sfcardwell have you ever been able to access the Administrator account?
  6. sfcardwell

    sfcardwell Techie7 New Member

    Messages:
    2
    Operating System:
    Windows XP
    Well, that didn't work. More details: XP Pro, no other OS. Full MS Office, some sim games, large music library. Administrator and Steve are in two groups: Administrators and Backup Operators. I can freely access both users. Neither user able to access restore wizzard, apparent rights problem. Tried work-around of removing, then giving back rights; no effect. Tried a few other fixes billed as fixing related problems, didn't work. I have some processes set at manual, a few disabled, thru services.msc, but don't think the problem is there. Note on my background: non-recent sysadmin, started up several PC networks, but little post-97 Windows experience (got in more technical area). Doubt I have bugs: McAfee scan regularly, firewalled and often locked down, incoming scan, IM blocked, several sleeper services manually stopped (but tried with them on also, same result). Services console and management console were not much help.

    Losing concentration, so I'll shut down for evening, resume after client meetings tomorrow. Maybe a bright idea will come.
    Steve
  7. townsbg

    townsbg Senior Member

    Messages:
    2,195
    Operating System:
    MAC
    Go to control manager, click on administrative tool, & then select "local security policy." On the left hand side under "local policies" select "user right assignments." In the main window look for & click on the "Back up files & directories" policy. Any user(s) or group(s) that you want to be able to create/use restore points must be listed here. If your user/group isn't listed you must add it. So add Steve or Administrator, or to cover both at the same time add the group Administrators or Backup Operators. That should allow you to use system restore points. The default entries are Administrators & Backup Operators. I've tested this & if your user or group isn't in this policy then you can't access restore points & will get the error below. I've also included a screen shot of the policy setting. If this doesn't help I don't know what will. Ok I discovered that you'll also have the same problem if your user or group isn't listed in the "Restore Files and Directories" policy Which is further on down the list. Good luck.

    Last edited: Jul 10, 2009

Share This Page