1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows Update

Discussion in 'Windows 10 Help' started by mattanddo, Sep 19, 2017.

  1. mattanddo

    mattanddo Established Techie7 Member

    Why, when I disable the windows update service which I have been doing for a few years now has it suddenly started re-enabling itself. WHAT IS CAUSING THIS ?????
     
  2. nukecad

    nukecad Established Techie7 Member

    MICROSOFT IS CAUSING THIS.

    You have asked this in 3 diferent threads now.

    In none of the threads have you said what edition of windows you are using -Home, Pro, Enterprise, (or even 10s) ?
    You have said you think it's version 1607.

    I hadn't realised what you are doing to try and turn off Automatic Updates. (Disabling the service).
    It won't work.

    Yes, you can still select 'disable' from Control Panel>Administrative Tools>Services>Windows Update>Properties.

    Windows 10 will re-enable it.

    Microsoft do not want you to turn off Windows 10 Automatic Updates.

    You may be able to defer updates for a time, but only if you have the Pro or Enterprise edition.

    The best you can do with the Home edition is set your network connection to 'Metered' - this will stop most, but not all, updates from downloading. (Until you connect to an unmetered connection again or click to allow them over the metered connection).
    Setting the connection to 'metered' used to stop all updates from downloading, but Windows changed it.

    I take it this is still about your Nvidia driver?
    I have just posted a possible solution in the first thread you made on this subject:
    http://www.techie7.com/threads/73114/
     
    Last edited: Sep 20, 2017
  3. mattanddo

    mattanddo Established Techie7 Member

    Home edition, version 1607, thought I had started the whole thing off by mentioning my method, this has been working now for over 3 years since the problem first started with NVidia update (have had the PC a lot longer than that and all was fine), have tried the metered approach but there is no option when I select the Ethernet route for my network, and yes it is 3 threads so I am sure you will understand and appreciate my frustration.
    I'll try the solution you have posted and advise, many thanks for your advice nukecad
    As I have a problem with the latest Nvidia Driver update I have for some time now been disabling the windows update service, periodically enabling it for the latest updates then disabling it again and replacing the Nvidia update with my older version which works fine. This process has been working fine for some time now. My problem now is that for some reason whenever I disable the windows update service it re-enables itself and keeps re-installing the problematic Nvidia update, this has become a daily and more frequent occurrence, what is happening now that didn't happen before

    mattanddo, Sep 11, 2017 Edit Report
     
  4. mattanddo

    mattanddo Established Techie7 Member

    Oh well looks like a new computer is required, already tried the wushowhide.diagcab had that on years ago right at the beginning of the problem and it never worked. Only the disabling update option ever succeeded and if that doesn't work any more .......
     
  5. nukecad

    nukecad Established Techie7 Member

    You don't need to buy a new computer, (unless you have some other major problem).

    I strongly suggest that you get your Windows 10 Home up to date to version 1703. It costs you nothing to do this.
    It should have done it automatically by now, but if you have been messing with the download settings.......

    Windows 10 is designed to keep itself up to date for all home users, that is why you can't turn automatic updates off.

    (It's also important for security, nobody on Windows 10 Home was affected by the recent WannaCry ransomeware attack because they had all been automatically updated with the defence against it. The only machines affected were older systems where automatic updates had been blocked).

    You are trying to fix a driver issue in an older Windows 10 version that may already have been fixed by Microsoft in version 1703.

    There were quite a few changes and fixes in the upgrade to 1703, you may find that your driver problem has been solved.
    This is your main problem isn't it, and the only reason you are trying to stop automatic updates?

    Go to Settings>Update & Security and Check for Updates.
    If that does not download and install 1703 (for whatever reason it can happen) then go and get the download and install it yourself.

    Go to this webpage and click on the 'Update Now' button to get started.
    https://www.microsoft.com/en-gb/software-download/windows10
     
  6. nukecad

    nukecad Established Techie7 Member

    Something has struck me as odd about what you are reporting as your situation -

    You insist that it is Windows Automatic Updates that is changing your driver.
    (In one of your threads you said you have checked this in the Windows Update History).

    And yet you say that you are running Windows 10 Home version 1607.

    Do you see the problem?
    If Automatic Updates are indeed running then they should have updated your Machine to version 1703.

    Can you post a screenshot of your Windows Update History so that we can see what the last updates on your machine actually were?

    It should look something like this (but may be slightly different if you are running 1607):
    Clipboard01.jpg
     
  7. mattanddo

    mattanddo Established Techie7 Member

    Responses below to close this issue off, thanks for you help:-

    You don't need to buy a new computer, (unless you have some other major problem).

    I strongly suggest that you get your Windows 10 Home up to date to version 1703. It costs you nothing to do this.
    It should have done it automatically by now, but if you have been messing with the download settings.......
    Not messing about BUT deliberately disabling the windows update to stop the non working NVidia driver constantly being installed.

    Windows 10 is designed to keep itself up to date for all home users, that is why you can't turn automatic updates off.
    I did this for a long time and it worked fine

    (It's also important for security, nobody on Windows 10 Home was affected by the recent WannaCry ransomeware attack because they had all been automatically updated with the defence against it. The only machines affected were older systems where automatic updates had been blocked).
    My PC was regularly updated especially around the WannCry and had the latest definitions, housekeeping was up to date I just then always had to remove the faulty NVidia update and replace it with my working one...then disable the automatic updating until I refreshed everything again

    You are trying to fix a driver issue in an older Windows 10 version that may already have been fixed by Microsoft in version 1703.
    Was never a problem until recently

    There were quite a few changes and fixes in the upgrade to 1703, you may find that your driver problem has been solved.
    This is your main problem isn't it, and the only reason you are trying to stop automatic updates?

    Go to Settings>Update & Security and Check for Updates.
    If that does not download and install 1703 (for whatever reason it can happen) then go and get the download and install it yourself.
    From Microsoft I now have 1703, windows creator update

    Go to this webpage and click on the 'Update Now' button to get started.
    https://www.microsoft.com/en-gb/software-download/windows10

    Something has struck me as odd about what you are reporting as your situation -

    You insist that it is Windows Automatic Updates that is changing your driver.
    (In one of your threads you said you have checked this in the Windows Update History).

    And yet you say that you are running Windows 10 Home version 1607.

    Do you see the problem?
    If Automatic Updates are indeed running then they should have updated your Machine to version 1703.
    I was never aware generational updates occurred via windows automatic update, and updates WERE regularly applied, previous occasions needed intervention to download and apply, maybe this has changed in 1703

    Can you post a screenshot of your Windows Update History so that we can see what the last updates on your machine actually were?

    It should look something like this (but may be slightly different if you are running 1607):
    It looked like your screen shot and showed NVidia, things have moved on now

    And finally following all updates, including the generation update, I have removed again the faulty NVidia driver and re-installed my working version I then Disabled the windows update service again and this time it has stayed disabled, (since last Thursday, so not sure what happened during the time I was having my problem)
    As I said earlier many thanks for you help nukecad
     
  8. nukecad

    nukecad Established Techie7 Member

    If you have got it working as you want again then that's good.

    Windows 10 version Upgrades have always worked through Automatic Update (although you can also go to the Microsoft website and download them yourself).

    Unlike previous Windows versions Windows 10 Home is meant to have Automatic Updates turned on all the time, unless you set your connection as metered.
    (Pro and Enterprise editions do enable you to defer them but not stop them altogether).

    This is because of the way Windows 10 works as 'a service', there are major version upgrades every 6 months or so, monthly 'cumulative' build updates on the second Tuesday of the month (Patch Tuesday) for improvements and the latest security patches, and often further 'cumulative' bug-fixes and critical security patches in between.

    eg. the last patch Tuesday was 13/09 (KB4038788), and a second 'cumulative' update was pushed out on 26/09 (KB4040724).

    If you disable your Automatic Updates altogether then you will not just stop the driver updates, but will also stop these updates that ensure you computer is as up to date as it can be, and as protected against newly discovered/newly written malware as Microsoft can make it.

    (Which was part of the problem with wannacry/wannacrypt, - MS had issued a security patch back in March, 2 months before the headline attack, but Vista, Win7, and Win 8.1 users who had their Automatic Updates turned off didn't get the patch and so were vulnerable).

    Like anything else it's your choice if you totally disable Automatic Updates in Win 10, but be aware of the downsides of doing so.