1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows Update

Discussion in 'Windows 10 Help' started by mattanddo, Sep 15, 2017.

  1. mattanddo

    mattanddo Established Techie7 Member

    How can I stop Windows 10 installing driver updates automatically ?
     
  2. nukecad

    nukecad Established Techie7 Member

    You usually set it during installation, but there is also a simple (but well hidden) setting for it, take a look at this 'how to'-

    http://winsupersite.com/windows-10/stop-automatic-driver-updates-windows-10

    You may have trouble finding the first screen as Microsoft keeps moving things about and so getting started is not quite as described in that article.

    And some of the wording in the screenshots has changed - eg. it now says 'manufacturers apps and custom icons' rather than 'driver software and realistic icons'.
    (See what I mean about well hidden).

    Open the Control Panel and click on 'System' that should get you on track with the article.
     
    Last edited: Sep 16, 2017
  3. mattanddo

    mattanddo Established Techie7 Member

    Thanks for this nukecad, got as far as device installation settings on the hardware tab in this guide BUT there are no further options as described in the guide, it just allows me to select No to the automatic updates, will have to see what happens now
     
  4. mattanddo

    mattanddo Established Techie7 Member

    This didn't work the updates happened again this morning despite this.
     
  5. nukecad

    nukecad Established Techie7 Member

    Hmmm,

    My windows 10 Home, V1703, build 15063.208 shows the following on the hardware tab:
    Clipboard01.jpg

    Clicking on 'Device Installation Settings' opens this:
    Clipboard02.jpg

    This is the screen that has been reworded from 'Driver software' to 'Manufacturers apps'.

    I do note that the final screen shown in that guide is no longer displayed when you click on No.

    If you look you will see that the No option has also been reworded from (let me choose what to do) to (your device might not work as expected), so it looks like they removed options and its now just on or off.

    EDIT.
    It also seems a bit odd that you say it updated this morning, are you sure that it is Windows that is doing this updating and not a third party driver updater that might be installed?
    (or even Nvidia themselves).
    If Windows is doing it then it should be listed in the Update History in the Update & Security settings.

    EDIT2.
    I know there was a problem back in 2015/16 with Win10 and Nvidia drivers, this was Microsoft' response to temporarily disable driver downloads, not sure if it will still work with 1703 but it may be worth trying the solution for 1607:
    https://support.microsoft.com/en-us...t-a-driver-update-from-reinstalling-in-window

    Alternatively try googling "windows 10 1703 nvidia" you will see you are not the only one having this problem, and the solution can be different for different systems, you may find a solution that works for your system.
     
    Last edited: Sep 17, 2017
  6. mattanddo

    mattanddo Established Techie7 Member

    Hi nukecad, yes I have the same graphics that you show and yes the updates do appear in the update history in update and security. I believe I have version 1607 not 1703 so will try that approach.
    What I can't understand is that this was never a problem when I disabled the windows update service historically BUT when I do that now it keeps re-enabling itself...
    Thanks anyway
     
  7. mattanddo

    mattanddo Established Techie7 Member

    Just a really quick update, minutes before the above post I had disabled the update service, removed the new NVidia update, re-loaded my usual NVidia driver and was trying the 1607 approach when the screen went black (this is the problem with the new NVidia update on my machine) I checked everything and the new update is installed again and the update service is re-enabled !?!?!?!?!?!?!?!?!
     
  8. nukecad

    nukecad Established Techie7 Member

    Well Windows 10 is constantly changing, so what happened historically is no guarantee it will keep happening.

    I'm a bit surprised to see you still have 1607, I know they were being cautious/slow rolling out 1703 but thought most home users had it as an automatic update in July.
    Have you though of manually updating to 1703?

    It's a change we will all have to get used to, instead of a major revision (service pack) ever year or so that happened with older versions, Windows 10 is constantly evolving month-to-month with bigger changes every six months.

    It will, and already is, changing the way 3rd party software developers have to work.
    They just get their programme patched for one Windows 10 change and Microsoft change something else.

    EDGE is a particular problem for some AV/malware/cleaner developers.
    And as you are finding Nvidia is another that seems to have constant problems with Windows 10 changes.

    Sorry but as I don't have Nvidia myself the best I can suggest for now is as I said above:
    "try googling "windows 10 1703 nvidia" you will see you are not the only one having this problem, and the solution can be different for different systems, you may find a solution that works for your system."

    Or have you looked at / joined the Geforce forums?
    https://forums.geforce.com/default/board/33/geforce-drivers/
    You are more likely to find a solution talking to other Nvidia users
     
    Last edited: Sep 18, 2017