1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Suddenly Unable to Connect To My Wireless Network

Discussion in 'Firewalls and Networks' started by Shadefyre, Apr 9, 2015.

  1. Shadefyre

    Shadefyre Established Techie7 Member

    Hey folks,

    As of yesterday, I have not been able to get my wireless card on my Windows 7 (x64) desktop to work. When it normally gives me connectivity issues, I simply do a quick uninstall/reinstall and it worked fine. However, after uninstalling it last night I could not get it to install correctly. I tried to set it up using the installation process cd it came with, however that never got past the "Detecting USB Card..." stage, as even with the card plugged in to various ports. To compound the problem, even after telling Windows to uninstall the card and remove the drivers, it would instantly reinstall the card's drivers when I plugged it in, despite still not showing up on the installer.

    The wireless card (a Cisco AE2500) would show up in device manager, and in network adapters it would show up but was disabled, and enabling wouldn't work, as in it would stay disabled. Running a troubleshoot on it just came up with "There might be a problem with the driver for the Wireless Network Connection Adapter."

    Not sure if it was a problem with the card or something worse, I popped across to Bestbuy and grabbed anther card to see if it would work (a D-Link N300). I ran the installer for that, plugged in the new card, it detected and installed the drivers. But, I still can't connect to my home network as I just get "No connections are available" and still get the "might be a problem with the driver" bit. However the card does at least appear as enabled in networking. I'm not sure what to try now. I know it's not the router, because the rest of my connections are working, including the laptop I'm writing this from.

    I should add that even when the wireless card is connected and "installed" as well as enabled, it doesn't show up at all in ipconfig.
     
  2. Digerati

    Digerati Super Moderator Techie7 Moderator

    Have you scanned for malware?

    If you enter the router's IP address in your browser's address bar, can you access your router? If you can, that means the adapter is working fine, but something is blocking Internet access - perhaps malware, or your firewall, or some security setting.
     
  3. Shadefyre

    Shadefyre Established Techie7 Member

    I've run a full system scan with Avast as well as boot-time scan, and didn't seem to come up with anything. Trying to connect to the router gives me an immediate Unable to Connect screen. The light on the wireless card doesn't even come on to indicate it's trying to connect.
     
  4. Digerati

    Digerati Super Moderator Techie7 Moderator

    Can you connect by Ethernet cable? Clearly there is something wrong with wireless (or maybe USB).

    Did you check your firewall settings? Did the D-Link show up in Device Manager - and with no errors?

    I would uninstall the wireless drivers and any software you installed with it. Then shut down, and remove the card. Then boot the computer with no card and make sure the drivers and any software is gone.

    Then shut down and install the card. Windows 7 should be able to detect the card and install its own drivers without you having to install any software or drivers that came with it.
     
  5. Shadefyre

    Shadefyre Established Techie7 Member

    I can't really connect via Ethernet, as I'd need 50-100ft of cable to run from the router in the basement to the computer on the second floor or to punch a pair of holes through the floor. I hadn't actually tried disabling the firewall before installing the card/drivers. The card does show up in device manager without any indicators, though the network adapters troubleshooter still says the device is experiencing issues. I'd like to think it's not a USB issue if only because the other USB devices aren't giving me any trouble (2 external HDDs, headset, mouse). I've tried uninstalling and reinstalling after rebooting, but I'll give it another go.
     
  6. Shadefyre

    Shadefyre Established Techie7 Member

    Nope, just plugging it in by itself just comes up with no driver found, and Windows only recognizes it as "802.11 n WLAN".
     
  7. Digerati

    Digerati Super Moderator Techie7 Moderator

    And that should work! But you can try installing the driver and see what happens. That said, I would download the latest driver from the D-Link website instead of from an installation disk to make sure you have the latest, but also so you don't get a bunch of other junk foisted on your system you don't need or want.

    Of course you do have to tell your WAP (wireless access point - may be integrated with a "wireless router) to allow your new adapter in because it will have a different MAC address and you no security until configured.

    Do re-enable your firewall before we forget. And I might try disconnecting all

    Try Microsoft Fix it.

    You said earlier you bought a new "card". Cards are installed in the "expansion slots", not USB ports. And "D-Link N300" is a whole line of products, including a D-Link N300 "Router". So do you mean you bought a N300 USB (not card) wireless adapter like this? These are fine if not too far away or you don't have to go through walls that contain metal wires or pipes.

    I might suggest you take that back and get a real "card" adapter with external antennas. I use this one and it works great for my computer that is in my basement on the opposite end of the house from my WAP. The external, high-gain antennas make all the difference. And some allow you to detach and raise the antennas for better reception too.
     
  8. Shadefyre

    Shadefyre Established Techie7 Member

    Sorry, I did mean a USB wireless dongle but I still refer to them as wireless cards. As for the WAP allowance, I've never had to make allowances for new wireless devices before. But the problem isn't even connectivity, because I'm not even getting to the point where Windows is acknowledging that I have a device capable of connecting. When the 802.11 n wlan shows up, it's under other devices with an error next to it, not network adapters. It's like something is interfering with the drivers or preventing Windows from accessing it as an adapter.
     
  9. Shadefyre

    Shadefyre Established Techie7 Member

    Well, I guess I've fixed the problem. I hadn't tried using the Troubleshoot problems subsection of Control Panel because I figured it would give me the same result as right clicking the device in control panel. But I happened to click through Troubleshoot Problems, Network and Internet, and then Network adapter. It ran, reset the device, and suddenly it's working as if there was nothing wrong. I wish it had at least told me what was wrong with it in the first place, for future reference, but the issue appears to be otherwise solved.
     
  10. Digerati

    Digerati Super Moderator Techie7 Moderator

    My guess is it was a problem with your IP and/or DNS settings the tools flushed and reset them.

    What I meant when I said you have to setup your WAP to allow access is because I am assuming you have your wireless security set so you need enter the SSID and passphrase to get in.

    At any rate, I am glad you got it sorted and thanks for the followup.